Unable to send SMS on iPhone

Hi everyone, I realize that this is not exactly privacy related question, but I hope that you can help me. First I thought that it’s related to the VPN (Mullvad), but it doesn’t seem to be the case.

My partner is using iPhone and the phone can receive SMS messages, but cannot send them. iPhone to iPhone (iMessage) works. Sending SMS doesn’t. We tried everything I found online* except completely factory resetting the iPhone.

*) reset network settings, disable vpn (mullvad), restart phone, reactivate iMessage, enable/disable “Send as SMS” function, send SMS from Mac, enable WiFi calling …

Any ideas? Thank you.

(Yes, I know that SMS is shitty.)

I know that enabling the firewall/kill switch on certain VPNs can cause this. Have you tried disabling those features in Mullvad?

Unfortunately it looks like that the iOS version doesn’t have a kill switch.

Q: Does the app have a kill switch?
The Mullvad app uses the “on-demand VPN” function in iOS which acts as a kill switch when the VPN is connected. It should not leak traffic (with some exceptions) as our VPN always appears as being “up”. It is not using “includeAllNetworks”.

Source: Using Mullvad app on iOS - Guides | Mullvad VPN

I checked the settings and the “on demand” switch was off. I even tried to delete he VPN configuration, restart the phone and try to send SMS. Nothing.

Anyway thank you Henry for your answer, good thinking.

Do you have the option of trying the sim in another phone? Just to make sure that’s not the problem?

Does that carrier package support SMS? Not all packages have this feature. It could also be a a configuration issue on their end. Give them a call, and see what they can do.

Sorry guys for the late reaction. SMS are included in the package and it sends SMS from a different phone :confused: