Pixel Dual SIM Dual Standby Verizon Mint Mobile ESIM

My build is a Pixel 4 XL, running Android 13 and CalyxOS 4.2.3.

Verizon physical SIM is chilling in SIM slot 1. Mint Mobile (T-Mobile) E-SIM is in SIM slot 2. With suggestions from this forum I got one step closer to getting set up.

Mint Mobile E-SIM

I am a premium member of IronVest previously Blur. I used a masked credit card, and masked email to purchase the ESIM from Mint Mobile. Without creating an account and without downloading the app, I used Mint Mobile Chat to activate the SIM requesting a specific area code by referring to a local zip code. After activation and getting a good activation code I was up and running.

Some issues and errors. In 2021, I tried using Mint Mobile and they did not offer E-SIM yet. I tried installing a Verizon E-SIM around Oct 2021 when they announced support for a Pixel 4 XL. I had to upgrade kinda from a Pixel 3 XL I was running LineageOS. I could not get the Verizon E-SIM to work after hours with Tech Support. Life got in the way.

I started recently with installing an E-SIM from Verizon. Perhaps I needed to have the eSIM provisioned on the account do the following steps:

Navigate: Settings>About Phone>MEID sim slot 2.

  1. Capture the IMEI (IMEI2) info.
  2. Tap OK.
  3. Contact Verizon Support to have the eSIM provisioned on the account with the info above.

Regardless I got this error repeatedly.

Subject Code: 8.2 and Error Code: 1.2 mean nothing to tech support on the tier 1 level. I only type this to pick up on a search.

I was getting the same errors with Mint Mobil just different codes.

With GrapheneOS I have heard you can not get get to the option to scan the QR code. I have MicroG installed with CalysOS so perhaps the Google ESIM is managed through MicroG.

The first auth code my instructions were similar to: Network & Internet > Add Mobile Network > Download a SIM Instead > Need Help > Enter Details Manually (close enough)

SM-DP+ADDRESS
cust-105-v4-prod-atl2.gdsb.net
ACTIVATION CODE
J80M3-78FQM-F4ET8-GRN0L

This code did not work. Round 2, Mint Chat Tech Support, suggested I do a reset of Settings>System>Reset Options>:

  • Reset Wi-Fi, mobile and Bluetooth. (Kicks you off chat)
  • Erase downloaded SIM’s. (my efforts, not their suggestion)

Then enter a code I did not capture in my notes looked similar to <cust-105-v4-prod-atl2.gdsb.net$J80M3-78FQM-F4ET8-GRN0L> and the E-SIM started downloading. I wish I captured better notes after this, as its one of the steps I didn’t repeat.

In conclusion with Dual SIM and Dual Stand by I have Verizon and T-Mobile service and I am happier I got Mint in the E-SIM vs having Verizon in the ESIM.