Phone stuck in boot loop

Been messing around with ADB today, removed some bloatware from my phone.
Everything seemed to be going okay, I’d try removing one package at a time and then checking if my phone is still working properly.

However I guess I accidentally removed something important as later on some apps started crashing on launch.
Figured I’d try doing a system reboot because for some reason that seemed like a good idea.
Then the phone got stuck on the verified boot loading screen.
There was absolutely nothing I could do from there, so I let the phone’s battery die.
And that made it worse because now the phone can’t even open past the first booting screen.
This isn’t my 1st time facing boot loops so I tried to fix it on my own, here’s what I did:

  • Tried doing a hard reset. The phone won’t do it.

  • Tried to go into safe mode, the reboots are happening way too fast for the phone to register the necessary imputs.

  • Accessed recovery mode successfully, tried wiping the cache partitions and rebooting but to no avail.

  • Tried to open download mode however this didn’t help with the issue.

  • Let the battery drain once again but the issue still persists.

  • Tried rerunning ADB commands however the device is not being recognized because It’s still not booted.

Just wanted to give it one last shot before I drop it to a technician or perform a factory reset.
If anyone has any ideas I’m happy to be trying anything as the phone is still boot looping as I type this.
PS: for anyone messing with ADB be very careful and learn from my mistakes!
Thanks for your replies!

2 Likes
  1. What phone do you have?

  2. What commands did you run?

I have an old Samsung J7 prime 2 which I’m desperately looking to replace.
I guess this is my cue lol
However my one flaw is that I don’t keep backups so there’s a lot of local data that is gonna be lost if I don’t recover the phone because there’s something inside me that thinks backups are bad (because of things like google photos etc…)

I booted into adb and ran the shell command, then I did this

Doesn’t help. Which packages did you remove?

I did not keep a list, however I distinctively removed every package that started with google.android and all the bloatware apps

I think I was able to trace the bootloop back to the device health app that I tried removing because It was crashing a lot.
I asked around on some other forums and some people said that it’s crucial for the system to work.
They also pointed out that I need to run fastboot commands via adb and use adb shell pm install-existing package name to reinstall it.
They also said something about trying to use TWRP to access ADB

Probably removed some system components.

look for some TWRP online video tutorials. I had the same problem and solved it due to some setting or action from TWRP and loading something.

I did, I believe I found the TWRP image specific for my device and I tried flashing it using ODIN, however the program would just mark the flashing as done and reset the phone.
When I tried booting into TWRP it just booted into normal recovery mode.
I honestly don’t know what I’m doing wrong and I’m kinda stuck. Is there any way to get ADB permissions from a boot-looped phone? What do you think Is the reason my TWRP is not working?

Update: Figured out that FAP lock was enabled and was the reason the phone couldn’t install the custom recovery image.
Any ideas on how to disable it?

watch this video first:

be patient and watch the entire video. it will go over reset issues.

this youtube video afterwards in case you need supplemental info:

How to Root Samsung Galaxy S9 and Galaxy S9 Plus (Exynos and Snapdragon Android 10 )-01dpUqz63BI.mp4

btw → be absoulute sure you have the right firmware for you phone. be sure the OS you are installing will install on your particular phone.

1 Like

Thank you I will take a look

1 Like

have you tried any fastboot mode for reflashing your stock semsung image .Though it will probably format your phone in process I am not aware if samsung allows it but certain vendors allow flashing a fresh stock image from fastboot. Some also have specific recovery tools for it.

Update:
I couldn’t flash TWRP recovery as Factory Reset Protection (FRP) was enabled and the only way to remove it was to access the phone.

Solution:
I got out of the bootloop by finding the exact same firmware model as my current one and reflashing it with ODIN.

A few things to keep in mind:

  • Make sure to download THE EXACT firmware version that you are currently running.

  • Make sure to use the HOME_CSC file and not the normal CSC file as using the normal one will wipe all user data. (what ended up happening to me)

  • This method is not guaranteed to keep user data however It’s probably your best bet according to my research. (provided you can’t flash TWRP)

  • If you have secure boot enabled you might encounter decryption issues.