I can't access my router settings, Could you help me please?

I tried to access my router’s settings but i was only faced by this error message

My router’s model is ZTE ZXHN H168N

P.s I can’t change my router with another privacy respected one cause something like PROTECTLI Vault router’s price is so expensive in my country as its price equals three times my salary

Try with http, not https, it says the problem is that TLS encryption.

It is just redirecting me to https although this option isn’t activated in the settings of my browser

I don’t know if you have tried a different browser yet, if not, I would recommend trying it in Firefox

I’ve always had trouble accessing local devices in Vanadium, router included. Firefox usually fixes the issue for me.

I tried many devices and many browsers but it is always the same result.

P.s it opened on an old version of Firefox but it was loading super slow, Same thing for Samsung browser of one of my family’s devices but on another Samsung device using Samsung browser it refused to connect, I’m so confused right now.

Check my reply to Duke Silver

Maybe try temporarily disabling any firewalls, VPNs, or the like. It’s a long shot, but it’s all I can think of given the information.