Firefox Cookies & site data

I have Firefox set to delete Cookies and Site Data when I close the browser.
I am also set to permanent private browsing mode.

However, I’ve noticed that no matter how many times I close Firefox or shut down there always remains data in Cookies and Site Data. I have to go to settings and delete it manually.
What am I doing wrong?
(I suspect it’s something really simple and dumb)

If you are on Mac you have to ‘quit’ the Firefox app.

Thanks. I’m not on Mac.
But is quitting different than closing Firefox?

On Mac you can close FireFox but it does not actually stop it, it essentially just hides the window.

Have you tried clearing the cookies manually and then checking to see if it works? I had a similar problem to this as well. Also check if you have any exceptions set.

Yes, I clear them manually every time I open Firefox.
But it seems like the entire purpose of that setting is to avoid having to do it manually and just automate it.

1 Like

I think that the cookies are your search engine preferences as I just had a look at mine.

So it is clearing your cookies but, every time you start Firefox your search engine creates cookies.

Most likely explanation:

If you are in PB mode then you get a new set of session cookies that doesn’t affect the currently stored cookies from a regular session. Those cookies are restored once you leave Private Browsing mode.
Try disabling PB mode and using the normal browsing mode, see if the problem persists which most likely shouldn’t.

This applies to Firefox on all platforms, you have to click the options button and hit quit for it to register as quitting and clear the data as simply closing the browser will keep everything the way it is.

Other Solutions as far as I know:

  • If all of the above isn’t the issue check if any sites have exceptions in the settings as these sites will be permitted to keep cookies even after quitting the browser.

  • Create a New Profile as a test to check if your current profile is causing the problems.

  • In some rare occasions extensions might keep a permanent cookie, try disabling and re-enabling each and checking if that’s what’s causing it

  • Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).
    Don’t make any changes on the Safe mode start window.

Useful Resources

Diagnose Firefox issues using Troubleshoot Mode | Firefox Help
Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems | Firefox Help

I did this in the most unscientific manner possible.
I applied several of the above suggestions at the same time and the problem has been solved.
But I’m not sure which one was the solution. :clown_face:
Thanks for the help everyone.
(How do I indicate “Solution” on this topic?)

Glad to help! As this topic is uncategorised there is no need to mark it as solved (though you could edit the title and put SOLVED in it.)